Chat with us, powered by LiveChat
Map
[mapsmarker marker="3"]
 

Your Cart

Help Phone

Support

 

Phone FAQs

How do I setup my Voicemail?
Step by step instructions are provided in our Phone Guide.
How do use my phone features?

You will find all a list of all of your phone features and how to access them in our Phone Guide.

Can I keep my current phone number?

In most cases, yes, you can keep your familiar phone number. We’ll do everything we can to make that happen. There may be the rare occasion when we are not able to transfer your number. If that is the case, we’ll discuss your options with you.

Will 911 work with my NewWave Phone service?

Absolutely. We know how important 911 service is, and it is part of your NewWave phone service. 411 service is also available.

 

Phone Troubleshooting

Issue: There is no dial tone.

Try these steps to re-establish the dial tone:

1. Check all phones to make sure they are all on the hook and have the proper power to function properly.

2. Check the lights on the MTA (Multimedia Terminal Adaptor).  The MTA is the devise your phone is plugged into that provides the service to you.  The power light should be on.  If the power light is blinking or all the lights are off, make sure the AC cord is securely plugged in the MTA and the outlet.

If all the lights are on, unplug the telephone wire from the rear of the MTA and plug another working phone directly into the jack on the MTA. Check that phone to see if you have a dial tone. If you do, then the problem is somewhere in the inside wiring or jacks.

 

Issue: There is static or an echo on the line

1. Check all the phones to make sure that the noise isn’t isolated to a single piece of equipment. If only one phone is receiving static, echoing, or noise then the problem resides with that particular unit.

2. If all phones have noise, unplug the telephone wire from the rear of the MTA (Multimedia Terminal Adaptor) and plug a working phone directly into the jack.  If you are receiving noise on the line try power cycling the MTA. This means unplug the power cord from the modem and take the battery out, when this is done correctly, no lights should be on the modem; wait at least 60 seconds.

3. Plug the power cord back into the modem, and put the battery back in. After a few minutes try the phone again and see if the noise is still on the line.

If you are still having static, echoing, or noise on the line please call 1.888.863.9928 for tech support.